3 книги в месяц за 299 

Справочник по настройке сетевого оборудования CiscoТекст

Читать фрагмент
Отметить прочитанной
Как читать книгу после покупки
Шрифт:Меньше АаБольше Аа

Коммутируемый виртуальный интерфейс Switched Virtual Interface (SVI)

Пример настройки приведен ниже.

sw1(config)#interface vlan 234

sw1(config-if)#ip address 10.10.234.1 255.255.255.0

sw1(config-if)#exit

Виртуальная локальная сеть (Vlan) на маршрутизаторах

На старых маршрутизаторах виртуальная локальная сеть задается другим способом, пример приведен ниже:

sw1#vlan database

sw1(vlan)#vlan 234 name ADMIN

sw1(vlan)#exit

Подводим итог:

sw1#conf t

sw1(config)#vlan 10

sw1(config-vlan)#name user_vlan

sw1(config)#vlan 11

sw1(config-vlan)#name management_vlan

sw1(config-vlan)#exit

sw1(config)#interface range f0/1 – 24

sw1(config-if)# description *** Access Interface ***

sw1(config-if)#switchport mode access

sw1(config-if)#switchport access vlan 10

sw1(config-if)#exit

sw1(config)#interface vlan 11

sw1(config-if)# description *** Management Interface ***

sw1(config-if)#ip address 10.0.11.2 255.255.255.0

sw1(config-if)#exit

sw1(config)#exit

sw1#wr

Мы создали две виртуальные локальные сети (vlans) для пользователей под номером 10 с портами от 1 до 24 и 11 для управления данным коммутатором, которой присвоили адрес 10.0.11.2. Обязательно в конце сохраняемся.

Магистральный порт (Trunk port)

Порт, предназначенный для множества VLAN, называется – Trunk port, магистральным портом. Протоколы магистральных портов ISL, 802.1q. Можно ещё вспомнить DTP (Dynamic Trunking Protocol), но он встречается редко в основном на очень старых коммутаторах.

ISL (Inter-Switch Link) частный протокол компании Cisco, может использоваться только на коммутаторах Cisco. Сразу стоит отметить, что на новых коммутаторах данный протокол уже не используется.

Мы задаем его сразу для двух портов, и для этого используем команду range, этой командой мы можем задать и большую область портов.

sw1(config)# interface range GigabitEthernet0/1 – 2

sw1(config-if)#switchport trunk encapsulation isl

sw1(config-if)#switchport mode trunk

Проверка осуществляется командой:

sw1#show interface trunk

802.1q открытый стандарт поддерживается всеми производителями, его мы и будем использовать, настраивается:

sw1(config)# interface range GigabitEthernet0/1 – 2

sw1(config-if)#switchport trunk encapsulation dot1q

sw1(config-if)#switchport mode trunk

На многих новых коммутаторах, достаточно ввести команду:

sw1(config)# interface range GigabitEthernet0/1 – 2

sw1(config-if)#switchport mode trunk

Так как протокол 802.1q используется по умолчанию.

Проверка осуществляется командой:

sw1#show interfaces trunk

Port Mode Encapsulation Status Native vlan

Gi0/1 on 802.1q trunking 1

Gi0/2 on 802.1q trunking 1

Port Vlans allowed on trunk

Gi0/1 1-1005

Gi0/2 1-1005

Port Vlans allowed and active in management domain

Gi0/1 1,30,33,42,51,54,234,243,300

GI0/2 1,30,33,42,51,54,234,243,300

Port Vlans in spanning tree forwarding state and not pruned

Gi0/1 1,30,33,42,51,54,234,243,300

Gi0/2 none

Также мы можем сменить native VLAN, она же не тегируемая виртуальная локальная сеть, по умолчанию она 1, но командой показанной ниже мы можем её поменять, к примеру, на 11:

sw1(config)# interface range GigabitEthernet0/1 – 2

sw1(config-if)#switchport trunk native vlan 11

Посмотреть изменения мы можем командой, показанной ниже:

sw1#show interfaces trunk

Port Mode Encapsulation Status Native vlan

Gi0/1 on 802.1q trunking 11

Gi0/2 on 802.1q trunking 11

Если нужно гарантировано отключить DTP (Dynamic Trunking Protocol) на магистральных портах, данный тип поддерживается старым оборудованием, делаем это так:

sw1(config)# interface range GigabitEthernet0/1 – 2

sw1(config-if)#switchport trunk encapsulation dot1q

sw1(config-if)#switchport mode trunk

sw1(config-if)#switchport nonegotiate

Последняя строка отключает DTP.

На магистральных портах, мы можем сделать ограничение по виртуальным локальным сетям (vlans), как это сделать показано ниже:

sw1(config)# interface range GigabitEthernet0/1 – 2

sw1(config-if)#switchport trunk allowed vlan 1-10

Существуют, также возможность удалит, добавить или исключить виртуальную локальную сеть (vlan) на магистральные порты или порт:

sw1(config)# interface range GigabitEthernet0/1 – 2

Удалили vlan 2:

sw1(config-if)#switchport trunk allowed vlan remove 2

Добавили vlan 2:

sw1(config-if)#switchport trunk allowed vlan add 2

Исключить 10 виртуальную локальную сеть:

sw1(config-if)#switchport trunk allowed vlan except 10

Подводим итог:

Для коммутатора 3560, который находиться в ядре или на уровне распределения, это выглядит так:

sw1#conf t

sw1(config)# interface range GigabitEthernet0/1

sw1(config-if)#switchport trunk encapsulation dot1q

sw1(config-if)#switchport mode trunk

sw1(config-if)#switchport trunk allowed vlan 1-10

sw1(config-if)#exit

sw1(config)#exit

sw1#wr

Для коммутатора 2960, который у нас является коммутатором уровня доступа:

sw2#conf t

sw2(config)# interface range GigabitEthernet0/1

sw2(config-if)#switchport mode trunk

sw2(config-if)#exit

sw2(config)#exit

sw2#wr

Сразу стоит отметить, что настройки на магистральных портах могут отличаться, от того, что приведено в данном примере. Мы ограничиваем доступ по виртуальным локальным сетям (vlans) на коммутаторе уровня ядра или распределения соответственно sw2 будут доступны только vlans с 1 по 10. При этом данные виртуальные сети должны быть созданы на обоих коммутаторах.

Проверка осуществляется командой:

sw1#show interface trunk

Port Mode Encapsulation Status Native vlan

Gi0/1 on 802.1q trunking 1

Port Vlans allowed on trunk

Gi0/1 1-4094

Port Vlans allowed and active in management domain

Gi0/1 1-10

Port Vlans in spanning tree forwarding state and not pruned

Gi0/1 1-10

Агрегация каналов EtherCannel 2 уровня

Позволяет объединять до 8 физических интерфейсов в один логический, создается на магистральных портах. Применяется для создания избыточности, следует отметить, что первые два варианта уже не используются и Cisco рекомендует использовать протокол LACP. Пример настройки приведен ниже:

sw1(config)# interface range fa0/19 – 20

sw1(config-if)# channel-group 12 mode on

sw2(config)# interface range fa0/19 – 20

sw2(config-if)# channel-group 12 mode on

EtherCannel 2 уровня Port Aggregation Protocol (PAgP) личный протокол Cisco, возможные применения Auto/Desirable-Desirable, настраивается так:

sw1(config)# interface range fa0/19 – 20

sw1(config-if)# channel-group 12 mode desirable

sw2(config)# interface range fa0/19 – 20

sw2(config-if)# channel-group 21 mode auto

EtherCannel 2 уровня Link Aggregation Control Protocol (LACP) открытый стандарт определенный правилом IEEE 802.3ad, возможные применения Active/Passive-Active, настраивается так:

sw1(config)# interface range fa0/19 – 20

sw1(config-if)# channel-group 12 mode active

sw2(config)# interface range fa0/19 – 20

sw2(config-if)# channel-group 21 mode passive

Подводим итог:

sw1#conf t

sw1(config)# interface range fa0/19 – 20

sw1(config-if)#shutdown

sw1(config-if)#switchport trunk encapsulation dot1q

sw1(config-if)#switchport mode trunk

sw1(config-if)#channel-group 12 mode active

sw1(config-if)#no shutdown

sw1(config-if)#exit

sw1(config)#exit

sw1#wr

sw2#conf t

sw2(config)# interface range fa0/19 – 20

sw2(config-if)#shutdown

sw2(config-if)#switchport trunk encapsulation dot1q

sw2(config-if)#switchport mode trunk

sw2(config-if)#channel-group 21 mode active

sw2(config-if)#no shutdown

sw2(config-if)#exit

sw2(config)#exit

sw2#wr

Мы подняли EtherCannel между двумя коммутаторами на портах 19 и 20. Стоит отметить команды shutdown и no shutdown при создании EtherCannel, они нужны для того, чтобы канал корректно поднялся.

Также стоит отметить, что после того как вы подняли Port-channel все изменения, к примеру добавление vlan, надо производить на интерфейсе Port-channel:

sw1#show run interface po12

Building configuration…

Current configuration : 127 bytes

!

interface Port-channel12

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1-10

switchport mode trunk

end

Проверка осуществляется командой:

sw1# show etherchannel summary

Flags: D – down P – in port-channel

I – stand-alone s – suspended

H – Hot-standby (LACP only)

R – Layer3 S – Layer2

U – in use f – failed to allocate aggregator

u – unsuitable for bundling

w – waiting to be aggregated

d – default port

Number of channel-groups in use: 3

Number of aggregators: 3

Group Port-channel Protocol Ports

––+–+–+–

1 Po12(SU) LACP Gi0/19(P) Gi0/20(P)

Агрегация каналов EtherCannel 3 уровня

Третий уровень обычно используется между уровнями ядра и распределения:

sw1#conf t

sw1(config)# ip routing

sw1(config)# interface port-channel 12

sw1(config-if)# no switchport

sw1(config-if)# ip address 10.1.1.1 255.255.255.0

sw1(config)# interface range fa0/19 – 20

sw1(config-if)# shutdown

sw1(config-if)# no switchport

 

sw1(config-if)# channel-group 12 mode on

sw1(config-if)# interface range fa0/19 – 20

sw1(config-if)#no shutdown

sw1(config-if)# end

sw1#wr

sw2#conf t

sw2(config)# ip routing

sw2(config)# interface port-channel 21

sw2(config-if)# no switchport

sw2(config-if)# ip address 10.1.1.2 255.255.255.0

sw2(config)# interface range fa0/19 – 20

sw2(config-if)# shutdown

sw2(config-if)# no switchport

sw2(config-if)# channel-group 21 mode on

sw2(config-if)#no shutdown

sw2(config-if)# interface range fa0/19 – 20

sw2(config-if)#no shutdown

sw2(config-if)# end

sw2#wr

Также важно помнить, что на коммутаторе должен быть включен 3 уровень, по умолчанию он может быть выключен, чтобы включить его надо ввести команду, показанную ниже, коммутаторами 3 уровня являются коммутаторы от 3500 серии и выше.

sw1(config)#ip routing

Проверка осуществляется командой:

sw1# show etherchannel summary

Агрегация

каналов

балансировка

нагрузки

(EtherChannel Load Balancing)

Ниже приведен пример настройки для простой сети.

sw1#conf t

sw1(config)#port-channel load-balance dst-ip

sw1(config)#end

sw1#wr

Возможна балансировка по разным значениям, ниже приведены возможные варианты:

dst-ip Dst IP Addr

dst-mac Dst Mac Addr

src-dst-ip Src XOR Dst IP Addr

src-dst-mac Src XOR Dst Mac Addr

src-ip Src IP Addr

src-mac Src Mac Addr

Проверка осуществляется командой:

sw1# show etherchannel load-balance

EtherChannel Load-Balancing Configuration:

dst-ip

EtherChannel Load-Balancing Addresses Used Per-Protocol:

Non-IP: Destination MAC address

IPv4: Destination IP address

IPv6: Destination IP address

Протокол

связующего

дерева

Spanning-Tree Protocol (STP)

Протокол связующего дерева, предназначен для предотвращения петель. Коммутаторы обмениваются BPDU (Bridge Protocol Data Unit) пакетами и на основании обмена данными пакетами выстраивают топологию, обмен пакетами продолжается и после того как была выстроена топология. Также происходит выборы корневого моста (bridge root), корневого порта (root port) и назначенного порта (designated port).Следует отметить, что по умолчанию на коммутаторах Cisco включен режим PVST+ (802.1d). В STP порты могут находиться в следующих состояниях:

Отключен (Disabled)

Слушает (Listening)

Изучает (Learning)

Передает (Forwarding)

Заблокирован (Blocking)

Модель STP выбирается при помощи команды указанной ниже:

sw1(config)#spanning-tree mode ?

mst Multiple spanning tree mode

pvst Per-Vlan spanning tree mode

rapid-pvst Per-Vlan rapid spanning tree mode

PVST+ (802.1d)

Протокол связующего дерева, включен по умолчанию, но он является не лучшим выбором, так как сходиться за очень большой промежуток времени, порядка 50 секунд. Существуют методы ускорения сходимости данного протокола.

Ниже показаны таймеры PVST+ и как их можно, изменить:

sw1(config)# spanning-tree vlan 1-4094 hello-time <1-10>

Hello timer 2 сек по умолчанию.

sw1(config)# spanning-tree vlan 1-4094 forward-time <4-30>

Forward Delay 15 сек по умолчанию.

sw1(config)# spanning-tree vlan 1-4094 max-age <6-40>

Max Age 20 сек по умолчанию.

Также существуют данные ниже команды, которые ускоряют PVST+, первая, ускоряет время изменения корневого порта,3-5 секунд, используется только на коммутаторах доступа. Вторая уменьшает сходимость max-age таймера, используется на всех коммутаторах.

sw1(config)#spanning-tree uplinkfast

sw1(config)#spanning-tree backbonefast

Проверка осуществляется командой:

sw1#show spanning-tree summary

Switch is in pvst mode

–– часть информации удалена –

Rapid-PVST (802.1w)

Более быстрый протокол связующего дерева, для его работы надо настроить команду portfast на всех портах доступа, то есть мы указываем команду switchport mode access на простых портах и добавляем команду portfast и коммутатор не проверяет эти порты во время работы протокола STP. Данная модель более предпочтительна.

Поэтому мы задаем следующую команду на нашем коммутаторе:

sw1(config)#spanning-tree mode rapid-pvst

Проверка осуществляется командой:

sw1#show spanning-tree summary

Switch is in rapid-pvst mode

–– часть информации удалена –

Протокол связующего дерева (STP) выбор корневого коммутатора

По умолчанию для 802.1d и 802.1w, корневой коммутатор будет выбран автоматический, но он может не совпасть с нашим корневым коммутатором или в результате добавления нового коммутатора в сеть, изменить всю топологию сети, поэтому настоятельно рекомендуется задать его самим. Ниже приведены два варианта команд:

sw1(config)# spanning-tree vlan 1-4094 priority 0

sw2(config)# spanning-tree vlan 1-4094 priority 4096

sw1(config)# spanning-tree vlan 1-4094 root primary

sw2(config)# spanning-tree vlan 1-4094 root secondary

В данном примере sw1 является первым корневым для всех виртуальных локальных сетей (vlans), а sw2 вторым корневым для всех виртуальных локальных сетей нашей сети.

Данная команда показывает, что данный коммутатор является корневым для vlan 9

sw1#show spanning-tree vlan 9

VLAN0009

Spanning tree enabled protocol rstp

Root ID Priority 9

Address 001b.544e.3280

This bridge is the root

Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec

Bridge ID Priority 9 (priority 0 sys-id-ext 9)

Address 001b.544e.3280

Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec

Aging Time 300

Interface Role Sts Cost Prio.Nbr Type

–– – – – – –

Gi1/0/6 Desg FWD 4 128.6 P2p

Gi1/0/7 Desg FWD 4 128.7 P2p

Gi1/0/8 Desg FWD 4 128.8 P2p

Gi1/0/9 Desg FWD 4 128.9 P2p

Gi1/0/10 Desg FWD 4 128.10 P2p

Протокол

связующего

дерева

балансировка

нагрузки

со

стоимостью

порта

(STP Load balancing with Port Cost)

Мы можем также управлять балансировкой при помощи изменения стоимости портов, по умолчанию стоимость гигабитного порта 4, с помощь команды показанной ниже можно изменить её как в большую, так и в меньшую сторону:

sw1(config)#interface Gi0/1

sw1(config-if)#spanning-tree cost <1-65535>

При назначении стоимости равной 1 данный порт будет корневым для коммутатора доступа:

Проверка осуществляется командой:

Show spanning-tree vlan <vlan number>

Протокол связующего дерева балансировка нагрузки с

приоритетом порта (STP Load balancing with Port Priority)

Также возможно изменение роли порта при помощи изменения приоритета:

sw1(config)#interface Gi0/1

sw1(config-if)#spanning-tree port-priority <0-255>

Проверка осуществляется командой:

sw1#Show spanning-tree vlan <vlan number>

Множественный протокол связующего дерева MST (802.1s)

Данный протокол также как и 802.1w достаточно быстрый и используется при очень большом количестве vlan. Настраивается:

sw1(config)#spanning-tree mode mst

sw1(config)#spanning-tree mst configuration

sw1(config-mst)#name MYVLAN

sw1(config-mst)# revision 1

sw1(config-mst)#instance 1 vlan 10, 11, 12, 13, 14, 15

sw1(config-mst)#instance 2 vlan 16, 17, 18, 19, 20, 21

sw2(config)#spanning-tree mode mst

sw2(config)# spanning-tree mst configuration

sw2(config-mst)#name MYVLAN

sw2(config-mst)#revision 1

sw2(config-mst)#instance 1 vlan 10, 11, 12, 13, 14, 15

sw2(config-mst)#instance 2 vlan 16, 17, 18, 19, 20, 21

sw2(config)#spanning-tree mst 2 root primary

Последней строкой задано, что второй коммутатор является корневым для 2 инстанции:

sw3(config)#spanning-tree mode mst

sw3(config)#spanning-tree mst configuration

sw3(config-mst)#name MYVLAN

sw3(config-mst)#revision 1

sw3(config-mst)#instance 1 vlan 10, 11, 12, 13, 14, 15

sw3(config-mst)#instance 2 vlan 16, 17, 18, 19, 20, 21

sw3(config)#spanning-tree mst 1 root primary

Последней строкой задано, что третий является корневым для первой инстанции:

sw4(config)#spanning-tree mode mst

sw4(config)#spanning-tree mst configuration

sw4(config-mst)#name MYVLAN

sw4(config-mst)#revision 1

sw4(config-mst)#instance 1 vlan 10, 11, 12, 13, 14, 15

sw4(config-mst)#instance 2 vlan 16, 17, 18, 19, 20, 21

Проверка осуществляется командой:

show spanning-tree mst configuration

show spanning-tree mst 1

Множественный протокол связующего дерева балансировка нагрузки со стоимостью порта (MST Load balancing with Port Cost)

sw1(config)#interface Gi0/1

sw1(config-if)#spanning-tree mst 1 cost <1-65535>

Проверка осуществляется командой:

sw1#show spanning-tree mst 1

Множественный протокол связующего дерева балансировка нагрузки с приоритетом порта (MST Load balancing with Port Priority)

sw1(config)#interface Gi0/1

sw1(config-if)#spanning-tree mst 1 port-priority <0-255>

Проверка осуществляется командой:

sw1#show spanning-tree mst 1

Подводим итог:

sw1#conf t

sw1(config)#spanning-tree mode rapid-pvst

sw1(config)# spanning-tree vlan 1-4094 root primary

sw1(config)#end

sw1#wr

sw2#conf t

sw2(config)# spanning-tree mode rapid-pvst

sw2(config)# spanning-tree vlan 1-4094 root secondary

sw2(config)#end

sw2#wr

Мы сделали первый коммутатор корневым для всех виртуальных сетей, а второй коммутатор, вторым корневым.

Проверка осуществляется командой:

sw1#show spanning-tree vlan «номер vlan»

Утилиты Протокола связующего дерева STP
Быстрый порт (Portfast)

Данная утилита STP позволяет порту пропустить состояния listening и learning и сразу перейти в состояние forwarding. Она используется только на портах доступа. При её включении поступает предупреждение, что к данному порту нельзя подключать коммутаторы, а только хосты.

Настраивается двумя способами:

В первом варианте вводиться одной строкой и применяется ко всем портам доступа, показано ниже:

sw1(config)#spanning-tree portfast default

Проверка осуществляется командой:

sw1#show spanning-tree summary

Switch is in rapid-pvst mode

Root bridge for: none

Extended system ID is enabled

Portfast Default is enabled

PortFast BPDU Guard Default is enabled

Portfast BPDU Filter Default is disabled

Loopguard Default is disabled

EtherChannel misconfig guard is enabled

UplinkFast is disabled

BackboneFast is disabled

Configured Pathcost method used is short

Во втором варианте и этот вариант более рекомендуем, настраивается на каждом интерфейсе, показано ниже:

sw1(config)#interface FastEthernet0/1

sw1(config-if)#switchport access vlan 9

sw1(config-if)#switchport mode access

sw1(config-if)#spanning-tree portfast

Отключается на интерфейсе командой:

sw1(config-if)#spanning-tree portfast disable

Проверка осуществляется командой:

sw1#show spanning-tree interface FastEthernet 0/1 portfast

VLAN0009 enabled

Или в развернутом варианте:

sw1#show spanning-tree interface FastEthernet 0/1 detail

Port 3 (FastEthernet0/1) of VLAN0016 is designated forwarding

Port path cost 19, Port priority 128, Port Identifier 128.3.

Designated root has priority 16, address 001b.544e.3280

Designated bridge has priority 32784, address 001b.2b24.2f00

Designated port id is 128.3, designated path cost 4

Timers: message age 0, forward delay 0, hold 0

Number of transitions to forwarding state: 1

The port is in the portfast mode

Link type is point-to-point by default

Bpdu guard is enabled

Loop guard is enabled by default on the port

BPDU: sent 33130, received 0

Защита

от

BPDU

пакетов

(Bpduguard)

Данная утилита используется на уровне доступа, она отключает интерфейс, переходит в состояние err-disable, при приходе на него BPDU пакета, используется вместе с portfast, чтобы после её срабатывания включить интерфейс, надо дать на заблокированном интерфейсе команду shutdown после этого набрать no shutdown.

 

В первом варианте вводиться одной строкой и применяется ко всем портам доступа, показано ниже:

sw1(config)#spanning-tree portfast default

sw1(config)#spanning-tree portfast bpduguard default

Проверка осуществляется командой:

sw1#show spanning-tree summary

Switch is in rapid-pvst mode

Root bridge for: VLAN0001, VLAN0116, VLAN0120

Extended system ID is enabled

Portfast Default is enabled

PortFast BPDU Guard Default is enabled

Portfast BPDU Filter Default is disabled

Loopguard Default is enabled

EtherChannel misconfig guard is enabled

UplinkFast is disabled

BackboneFast is disabled

Configured Pathcost method used is short

–– часть информации удалена –

Во втором варианте, настраивается на каждом интерфейсе, и мы используем этот вариант, применение показано ниже:

sw1(config)#interface FastEthernet0/1

sw1(config-if)#spanning-tree bpduguard enable

Отключаем командой показанной ниже.

sw1(config-if)#spanning-tree bpduguard disable

Проверка осуществляется командой:

sw1#show spanning-tree interface FastEthernet 0/1 detail

Port 1 (FastEthernet0/1) of VLAN0009 is designated forwarding

Port path cost 19, Port priority 128, Port Identifier 128.1.

Designated root has priority 9, address 001b.544e.3280

Designated bridge has priority 32777, address 001b.54cb.e580

Designated port id is 128.1, designated path cost 4

Timers: message age 0, forward delay 0, hold 0

Number of transitions to forwarding state: 1

The port is in the portfast mode

Link type is point-to-point by default

Bpdu guard is enabled

Loop guard is enabled by default on the port

BPDU: sent 167665, received 0

Бесплатный фрагмент закончился. Хотите читать дальше?
Купите 3 книги одновременно и выберите четвёртую в подарок!

Чтобы воспользоваться акцией, добавьте нужные книги в корзину. Сделать это можно на странице каждой книги, либо в общем списке:

  1. Нажмите на многоточие
    рядом с книгой
  2. Выберите пункт
    «Добавить в корзину»